[Bug] Error on Saving

Hi guys, I’ve encountered an error that prevented me from saving.


So a bit of background on the bug, Valkyrie was saving properly a couple of days ago, but after working on it some more today, I encountered this error upon saving. So I reloaded the project as I have only worked on it for about an hour or so in order to try and reproduce the bug by retracing my steps, and I think I’ve found the problem…

What I did was to try saving again after it reloaded to make sure that it wasn’t an admin rights problem as I’m using Win 10, and indeed it wasn’t as I could save it at this point in time. Next, I placed a dummy in my scene and I dragged my existing models into the dummy in order to organize my scene, then I tried saving again and then this is when the error appears. I tried backtracking slightly by dragging the models back out of the dummy and then saving again, but the error still triggered.

So for now I’ll temporarily refrain from organizing my project as it’s quite urgent that I need it to be working while it’s being looked into… It’d be great if there’s a workaround too.

Additional FYI, I’m using the latest version of Valkyrie downloaded from the main download link from the homepage (20190529_1451).

Thank you for your time!

That seems odd, I will test locally, using Dummies for organisation is something we do very often, I would hope its not broken :slight_smile:

In the meantime you should still be able to save by press “Ctrl+Shift+S” it’ll save in a new level named “LEVELNAME_1”, next time you save it’ll be _2, and so on.

A quick question, how did you name that Dummy? Its possible that there’s issues with characters that your OS doesnt allow as filenames, on Windows I think :, \, / are a problem.

I tried to reproduce this error here but I couldn’t. Can you post a screenshot of the timeline with the dummy in question highlighted?

Yeah I’m aware of that as I used dummy after learning from the architecture template in Valkyrie so I found it weird too… I’m not able to reproduce it again now even though I used the same method…

Right now my timeline looks like this:


The most I’ve used is the ‘underscore’ as far as special characters go… I’ll try ctrl+shift+s if the bug reappears again.

Thanks for the reply and help, really appreciate it! :slight_smile:

These look good and shouldn’t cause any issue. Please let me know if you see the problem again.

Note that I’ve tried all the weird characters I could think of, including the ones I mentioned above and they don’t cause any issue for file saving. The issue is only if you use those in the level’s name (since that ends up as the file name on disk), entities inside your scene can be named pretty much anything.

Happy to help :slight_smile:

Hi I’ve encountered the error again but this time I was just moving the camera around so now I’m all out of clues… But the good thing is that ctrl+shift+s is working and then subsequently saving after that corrected the error i.e. the error no longer pops up… so I guess this is the current workaround for this issue until there’s more info on what’s really causing it.

Hope this helps!

1 Like

Can you send me your Vlk log files? It should be in your $USERNAME\Documents\Logs folder, if you could zip that folder and send it over after the error occurred I might be able to infer what is causing the failure from there. You can email it at pierre [at] talansoft.com.

1 Like