Issue loading .vpk into We3D on iPadPro

Hi There,
When I download a .vpk file to my ipad, there is no option to say “Open in We3D”. Therefore I cannot load the file into the We3D app.

Drag-drop into the content screen does not work either.

I have also tried entering the IP address, but my browser will not connect.

Any help appreciated.

Thanks

The “Open in We3D” should be there, if you slide all the way to the right on your iPad you should have a “…” icon, it might be hidden in there. This should work from the Files app or any app capable of sharing files.

For the IP to work you have to make sure that both devices are on the same network otherwise they likely wont be able to connect.

Hi Pierre,
Sorry, if I swipe to the right I am only able to delete the file.

I have also tried the ‘copy to we3d’ option. This switches to the app, but nothing happens.

Also, I am unable to get the sample scenes in the Home section to work, clicking in the project or Vpk button leads to the progress download bar freezing at 10%.

Hi there,
While we look if there is any problem, have you tried this?
Make sure that your computer and your iPad are on connected on the same Wifi network as the one indicated in We3D right-hand side hamburger menu:
image
then type the IP address in your computer browser:
image
Then drag & drop your vpk in the interface.
The vpk should be in your content then.
Cheers,
Guillaume

Copy to We3D must have copied the file. Can you check your content folder? Your vpk should be there.

Hi Guys,
I have connected to the We3D web interface on the iPad using Safari, it seems that Chrome did not work.

This iPad also has the .vpk downloaded to it. However, when I try to drag/drop or use the Upload files button to load the file I get the error message as seen in the above screen shot.

Unfortunately that wont work because iOS closes the web server as soon as We3D is put in the background. The web server is meant to be used with We3D opened on your iOS device and a desktop browser, usually where you have Valkyrie installed.

It looks like “Open in We3D” in the Files app doesn’t work correctly. We implemented the sharing but Files works differently, and we didn’t know that. Right now “Copy in We3D” works if someone sends you a Vpk on Slack, Whatsapp, by Email, etc… We’re working on a fix for the Files app right now.

Here’s how it looks with regular apps:

In the video I use an app to browse a FTP server. “Send Copy” is called “Share” in some apps. We’ll have a fix for the Files app & home page in the coming days, most of that will be waiting for Apple to approve the update…

I’ll post here as soon as the new version up.

Thanks Pierre. I will try the webserver/broswer method when I get out of the office, there I can be sure that I am on a shared open network.

Also thanks for the video, it’s helpful.

D

Thank you for your patience, and sorry for the trouble :slight_smile:

Hi Guys,
OK I can confirm that using the web server drag/drop method worked for me. So my earlier issue with this method was that I wasn’t on a shared/open network. It also worked to email the .vpk, and then use the ‘Send Copy’ method.

Thanks for your help.
D

Great to hear, thanks for letting us know. Will let you know when the new We3D build that fix the issue with the Files app is up.

Hi there,
The new We3D version is up on the app store, there should not be any problems annymore.
G

Here’s a quick video of the drag’n drop from the “Files” app:

1 Like

Thanks Guys, I can conform that is working for me now.
D

2 Likes